Driver Update for Isaac Sim

I’ve recently installed the newer version of Isaac Sim from Omniverse (Version 2021.2.1), but I’m unable to see anything in the view port. Version 2021.1.1 doesn’t have this issue, but starting with 2021.2.0 it does. According to the logs, the scene is unable to do the rendering. The error appears to be that the driver doesn’t meet the requirements, so I tried to update it following the instructions from: 1. Isaac Sim Requirements — Omniverse Robotics documentation. However, the command doesn’t allow the update since the GPU is in use. From what I understand, the driver is being used by the monitor and if I disable it, I can’t see anything. How can I perform the driver update?

What about sudo apt install nvidia-driver-470?

Unfortunately, it is unable to perform the update. The log reads:

Reading package lists… 0%

Reading package lists… 100%

Reading package lists… Done

Building dependency tree… 0%

Building dependency tree… 0%

Building dependency tree… 50%

Building dependency tree… 50%

Building dependency tree

Reading state information… 0%

Reading state information… 0%

Reading state information… Done

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-470 : Depends: libnvidia-gl-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: nvidia-dkms-470 (= 470.82.01-0ubuntu1)
Depends: nvidia-kernel-source-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-compute-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-extra-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: nvidia-compute-utils-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-decode-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-encode-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: nvidia-utils-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-ifr1-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Depends: libnvidia-fbc1-470 (= 470.82.01-0ubuntu1) but it is not going to be installed
Recommends: libnvidia-compute-470:i386 (= 470.82.01-0ubuntu1)
Recommends: libnvidia-decode-470:i386 (= 470.82.01-0ubuntu1)
Recommends: libnvidia-encode-470:i386 (= 470.82.01-0ubuntu1)
Recommends: libnvidia-ifr1-470:i386 (= 470.82.01-0ubuntu1)
Recommends: libnvidia-fbc1-470:i386 (= 470.82.01-0ubuntu1)
Recommends: libnvidia-gl-470:i386 (= 470.82.01-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

I was able to solve it by changing the target boot to text and purging nvidia driver and dkms. After which, I installed the new driver and switch the boot back to GUI. The driver now shows up as 470 and Isaac Sim 2021.2.1 is now able to load the scene. Thanks for the help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.