Error connecting to localhost with Nucleus service

I recently installed the omniverse app and having issue with connecting to nucleus service. Everytime I try to connect to localhost, it gives failed to connect to server error. By clicking the hamburger icon beside it all services are running expect Authv.1.5.2-1819 for me. Everytime I try to start or restart, it gives error and automatically stops. I have try uninstalling and reinstalling but same issue.

@user55464 the auth service not running is most likely the reason why you aren’t able to authenticate. do you have any firewall, antivirus, or windows defender active? if so, the first thing to try is turning them off temporarily and see if the behavior persists.

if inclined, you can try uploading your launcher log for further assessment.

@Simplychenable Thank you for the reply. I did try turning off the Antivirus but still the same result. I’m attaching the launcher log as well.
launcher.log (15.4 KB)

Please uninstall and re-install and try again fresh

Then go to settings and make sure you can get to this page

@Richard3D Thank you for the reply. I did clean reinstall and got the same issue. Everything except Auth is running fine. Everytime I try to start Auth, it runs, gives error and then stops.

Could I get your Nucleus logs and know what OS you are on.
It’s possible that the port may be taken up already. Can you restart the computer and try again.
Let’s get your “auth” log. See the image below

Attaching the “auth” log file. I’m on windows 11 and restarting the PC results in same issue.
Auth (3).log (23.4 KB)

Alright we can take a look

@Richard3D Just following up to know if there’s any update regarding the issue mentioned. Thank you.

Hi, I encountered similar problems, but the auth log has nothing at all. And besides the “Auth” service, the “Discovery Service” is also stopped (no log either). And when I click “Configure ports”, there are no ports.

I have tried to clean omniverse using the clean-up tool twice and downloaded the lastest omniverse launch but it did not help. I also tried to connect to different networks, enable and disable the VPN. But with no success.


@user55464 @AlanSunHR we’d need to see the output of the executable. It seems to be crashing before it finishes initializing.

Please go to the install directory (in windows it’s usually %LOCALAPPDATA%\ov\pkg\nucleus-workstation-\Auth), replace the with the version number you have installed.

Then in a cmd shell, please run
omni-auth-service.exe 1> D:\testFile.txt 2>&1 if this is Windows
omni-auth-service > ~/testFile.txt 2 if Linux

these commands should capture the output of the application on launch to help us understand what the issue is.

Thanks for the reply! The service did have some problem:

And here is the output of the command:
testFile.txt (1.2 KB)

The discovery service also had the same issue, while other services seemed to work properly. How can I solve this problem?

@AlanSunHR , what version of Linux are you running. The error is complaining about needed GLIBC version not existing.

Hi @dlindsey , Thanks for the reply!

I am using Ubuntu 18.04LTS.

Sorry, we support Ubuntu 20.04 LTS and above (recommend 22.04 LTS)
Hardware Sizing Guide — Omniverse Nucleus latest documentation (nvidia.com)

Hi, @dlindsey ,

Is it possible to install an old version of Nucleus?

I don’t think it’s advisable for you to install an older version of our software to work around this issue. That would be a disservice. It would be better for you to update your OS to our minimum specs, and install the latest version.

Is there a reason you cannot update your OS? It is very behind.