Fail to install boost 、flann

Please provide the following info (tick the boxes after creating this topic):
Software Version
[*] DRIVE OS 6.0.8.1
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
[*] Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
[*] DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
[*] native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

zhangzs@tegra-ubuntu:~$ sudo apt install libboost-all-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libboost-all-dev : Depends: libboost-graph-dev but it is not going to be installed
Depends: libboost-iostreams-dev but it is not going to be installed
Depends: libboost-log-dev but it is not going to be installed
Depends: libboost-mpi-dev but it is not going to be installed
Depends: libboost-mpi-python-dev but it is not going to be installed
Depends: libboost-python-dev but it is not going to be installed
Depends: libboost-regex-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

zhangzs@tegra-ubuntu:~$ sudo apt-get install libflann-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libflann-dev : Depends: libhdf5-mpi-dev but it is not going to be installed
Depends: liblz4-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

why?

zhangzs@tegra-ubuntu:~$ sudo apt-get update
Hit:1 Index of /ubuntu-ports focal InRelease
Get:2 Index of /ubuntu-ports focal-updates InRelease [128 kB]
Get:3 Index of /ubuntu-ports focal-security InRelease [128 kB]
Reading package lists… Done
E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-updates/InRelease is not valid yet (invalid for another 174d 17h 46min 4s). Updates for this repository will not be applied.
E: Release file for http://ports.ubuntu.com/ubuntu-ports/dists/focal-security/InRelease is not valid yet (invalid for another 170d 8h 56min 53s). Updates for this repository will not be applied.

Dear @deng.shigang ,

Looks like time issue on target. Could you verify the time on target and fix it.

Dear @deng.shigang,
Please use NVOnline to seek support. Do you still have issue with NVOnline access ? If so, did you check with PM on it?

zhangzs@tegra-ubuntu:~$ sudo apt-get update
Hit:1 Index of /ubuntu-ports focal InRelease
Hit:2 Index of /ubuntu-ports focal-updates InRelease
Hit:3 Index of /ubuntu-ports focal-security InRelease
Reading package lists… Done
zhangzs@tegra-ubuntu:~$ date
Wed Jun 5 13:45:36 CST 2024
zhangzs@tegra-ubuntu:~$ sudo apt-get install libflann-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libflann-dev : Depends: libhdf5-mpi-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
zhangzs@tegra-ubuntu:~$ sudo apt-get install -f
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 175 not upgraded.
zhangzs@tegra-ubuntu:~$ sudo apt-get install libflann-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libflann-dev : Depends: libhdf5-mpi-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

we fix the time issue.but we still can not install libflann-dev.

We have communicated with Nvidia PM. Although we belong to BYD Company, our project is not a mass production project, so Nvidia PM will not open an NVOnline account for us, and we are advised to get help through the forum.

Could you check the suggestion listed in Fixing "Unable to correct problems, you have held broken packages" and see if it helps to fix?

zhangzs@tegra-ubuntu:/srv/nfs/driveworks-aarch64-linux-gnu$ sudo apt-get install libibverbs-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libibverbs-dev : Depends: ibverbs-providers (= 28.0-1ubuntu1) but 58mlnx43-1.58101 is to be installed
Depends: libibverbs1 (= 28.0-1ubuntu1) but 58mlnx43-1.58101 is to be installed
E: Unable to correct problems, you have held broken packages.
zhangzs@tegra-ubuntu:/srv/nfs/driveworks-aarch64-linux-gnu$ sudo apt remove libibverbs1

thanks,by remove libibverbs1.