Freezing issue Jetson AGX Orin Developer Kit

I unpacked my new Jetson Orin around two weeks ago. Since the very first day, I have been experiencing a strange freezing problem.

Mouse suddenly freezes for about 20 seconds. During the freeze, I can see the cursor blinking, however I cannot control it with keyboard neither (i.e. keyboard and mouse do not work during the freeze). My inputs during the freeze seems to be received by Jetson because the arrow instantly moves to somewhere else when the freeze is over.

I use Jetson mostly for processing of video frames. Sometimes my program suddenly stops producing output without giving no error. In that case I have no option than manually terminating the program and re-running it. I suppose this problem may be related with the freezing problem. I would like to solve this problem before proceeding more in my project because it will be pretty annoying to reinstall all the packages.

My JetPack version: 5.0.1-b118

I found a similar topic in the forum but no solution is provided:


i had the same problem and to be honest, it still happen some time. I did not find the reason. I plugged the mouse and keyboard on the other USB ports and this issue happens less often. Maybe you could try to find the best USB ports for your mouse and keyboard ?

Now, my jetpack version is 5.1 and i don’t have this issue any more but i did not use the AGX Orin with JP 5.1 for a long time so i can’t say the issue is definitively solved. Just have to wait and see.

Maybe Orin gets an issue with USB management under JP 5.0.1 ? I don’t know.


For Orin, the latest release is Jetpack 5.1. Please try to re-flash system image to this release and try again. You can install SDKManager on host PC for flashing system image and SDK Components to Jetson devices.

Hi DaneLLL,
I have been considering the option of re-flashing and updating the Jetpack to 5.1. However, I should say that I do not the official documents/tutorials clear enough. They are indeed confusing with lack of explanation. Therefore, I would opt for simpler solutions before trying the re-flashing option.
At this point, I need some clarifications (given below). Could you please answer them.

1- Can I update the Jetpack version to 5.1 using the instructions given here:
This one looks like a solution that does not require flashing. Is that correct?

2- The link below seems to be the best I managed to find about flashing jetson using sdk-manager. However, I still cannot figure out how difficult it will be. I suppose that GUI of the sdk-manager have plenty of explanations during flashing. Can you confirm that? I am also wondering if flashing operation completely removes all the files in the system? I am trying to figure out if I will need to setup my python environments again.


Hi easybob.
Thanks for the advice. I have just switched to the other usb ports. I will share here if there is any significant update. In the meantime, I would appreciate any recommendations/links for updating the jetpack to version 5.1.

I use this method to update jetpack :

But i must say i had a severe issue : after update, i had to reboot the AGX Orin and then … nothing. The AGX was dead.

So i had to go to recover mode and use a laptop (under Ubuntu, using SDK manager) to reinstall the system on the AGX Orin.

This link will explain the procedure :

It is not really complicated but to be honest, i thought first i lost my AGX Orin. Not really funny. At last, everything is ok now.


I have been using my Jetson Orin for last 7+ days with JetPack 5.1. The freezing issue happened only once just after flashing. So, I assume that the problem has been solved.
The tutorial for flashing is very useful. It is easy to follow and understand. In my case, the step for setting the board in recovery mode was not helpful. So I simply followed the instructions in Nvidia’s official page. Once the SDK manager detects Jetson Orin, it is pretty easy.

Cool. I also don’t have mouse keyboard freeze with Jetpack 5.1 so it seems the problem is solved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.