Jetson nano 2GB is not working anymore

I have a jetson nano 2gb and I’m trying to do the setup by following the getting started tutorial. Yesterday it was working fine (except for the fact that it was too slow but at least it worked), however had to disconnect it in the middle of configuration.

Today I tried to complete the configuration, but it won’t boot. The LED light is on but the monitor isn’t showing anything (it doesn’t even recognize that there is a device connected)

I tried formatting the SD card and flash the image again but nothing has changed.

I’m using a 64GB class10 micro SD card and a 5.1V 3A power supply.

I know the problem is not in the monitor because I tried on a different monitor and still nothing happend.

Hello @biocorepm

Can you connect and check the logs from the debug USB port?

I tried Jetson Nano 4GB with 5V 3A power supply. Initially the first NVIDIA logo appeared and after a few seconds later it closed. Then, I tried it with 5V 2A DC adapter and it worked. I’m not sure how this happening

Sorry, I’m a bit new to this. How can I check the logs from the debug USB port? Do you know any tutorial that I can check?

As you can see that, Jetson Nano 2GB Developer Kit User Guide | NVIDIA Developer

You should plug your micro-USB cable between Jetson Nano’s J13 pin and your linux OS PC’s USB port. Then you should use a serial-communication software like “gtkterm”.

These commands are working for Ubuntu (and should work other debian OS’s)
If you want to install gtkterm type this:
sudo apt install gtkterm

After USB connected
you can see that the FTDI connected with “lsusb”

Then you can connect your Nano with:
sudo gtkterm

Finally, set the port and baud rate like that:

Regards