Jetson Nano No output on HDMI but VLC is working

I had sent this unit back for RMA when I couldn’t get any signal from the HDMI port, and found that the replacement had the same problem. I also found that an older version of Jetbot did seem to work, but no longer does

I’m getting good output via VLC (using vino) so I know the thing is working but I c an’t figure out what changes to settings should be made so that I can get HDMI out

I don’t have a DPT monitor, but I do have a DPT-HDMI converter, which also doesn’t work

I’ve tried the HDMI on 3 different monitors, and none of them seem to work

I’ve looked thru the forums with people having the same issue, but I haven’t found the one that actually solves my problem

I did have it working on an older version of Jetbot, but, something changed, and it no longer does. I’ve even tried flashing an old version of Jetbot, which no longer seems to work


I think you could tell us these info too.

  1. What is the jetpack version you are using?

  2. Please connect one HDMI monitor and share me the full dmesg as text file.

I must’ve played with it too much cuz now it no longer boots, but I did manage to save the dmesg log before it crashed

The JetPack version is 4.41 and the dmesg log is herelog.txt (57.7 KB)

Since it no longer booted, I downloaded a newer version (JP4.5) from and that one does output to HDMI, so there must be a setting in jetpack if I keep having this issue on only certain versions

Is affiliated with Nvidia ? Should I be trusting their software ?

You can directly flash your board with sdkmanager and see what is the result.
I don’t use jetbot recently, so cannot guarantee what is released in their package.

As for your dmesg, there is no error. The log just tells me there is even no hdmi plug event. If you confirm the hdmi cable is not broken, I could only guess the port has defect…

Also, how do you know the board is no longer booting? Does the LED still light up?

The power LED I installed comes on, but the I2C LED display I installed for Jetbot doesn’t do anything, the fan doesn’t come on, and the lights on the ethernet port don’t flash and I get no response on SSH or VNC

As for the cable, I’m using the same cable in this new (working) version as I was with the previous version that didn’t work

I’ve tried to install the sdkmanager, but it fails with this…

The following packages have unmet dependencies:
 sdkmanager:amd64 : Depends: libgconf-2-4:amd64 but it is not installable
                    Depends: libcanberra-gtk-module:amd64 but it is not installable
                    Depends: locales:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Is one of those downloads an image with the sdkmanager already installed ? That could save some effort

I don’t know how to tell if this OS is a true 64 bit, or a 64 bit with a 32 bit userland, and I’m not even sure if that’s the problem with installing the sdk, I thought this was an ARM not AMD

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


Sdkmanager needs to run on a amd64 machine. It means you need to find a x86 host and install the ubutnu 16.04 or 18.04 host on it. The website of sdkmanager shall have those info…

If ethernet is gone, then why can you still use vino? Do you still have any method to access the board?