Jetson Orin NX 16 GB with Seeed studio A203V2 carrier board

Hello,

I bought the A203v2 carrier board for my Jetson Xavier NX. For the past year, it has worked fine without any issues.

I recently bought an Orin NX 16GB module to replace the Xavier NX. Before installing the Orin NX to the A203v2 board, I installed it onto a Xavier NX DevKit board along with a 1TB nvme SSD and flashed Jetpack 5.1.1 (using the Nvidia SDK manager). Flashing went fine and the Orin NX booted into Jetpack 5.1.1 with no issues whatsoever.

I then installed the Orin NX module and the SSD on the A203v2 carrier board. However, I am not able to boot with the Orin NX on the A203v2 board. Nothing shows up on a display connected to the HDMI port. I waited and tried accessing the board through SSH (via USB connection) with no luck. Seems something is stuck during boot. Note that there is no other device other than the monitor connected to the carrier board.

According to this spec sheet, the Leetop A203 board supports Orin NX. It looks exactly the same as the Seed Studio A203 board that I have (possibly they are even made in the same factory).

Any help is greatly appreciated!

Best,
Tahmid

For Seeed studio A203V2 carrier bord, it’s different than our devkit carrier board, you need to get the specific BSP to have it working.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.