Jetson TX2 module powering off automatically

Hi, I am running into an issue the Jetson TX2 board that I am working with. Here’s the current situation on the Jetson TX2 board:

While running a script that was using the onboard camera for a few hours to get some image processing (YOLOv3) data, the board turned off abruptly. Leaving the CR5 and CR2 lights on while the CR6 led was flashing slowly. After leaving the board off for 30 minutes or so, I tried turning on the board again. This resulted in having the CR5, CR6, CR1, and CR2 leds one which should indicate that the board is working perfectly. However, when I tried plugging in the peripherals (HDMI, USB Hub for mouse and keyboard), none of them were responsive. I also tried to SSH into the device using the Ethernet port. However, I could not establish a connection. I was looking into the forums for any users that had the same issues of not having any functionality in the HDMI and USB ports but none of them had an absolute solution on the issue. I double checked if any of the capacitors had any bumps due to discharge or any contacts having burn marks due to shorting among the exposed contacts but found no signs of any visible hardware damage.

Hi, do you have any log? That is helpful to debug.

Unfortunately, I cant get a display from the board.

You mean the board failed to boot up? If so, the board might be damaged and should be repaired.

Is there somewhere I can try to send the board to for any hardware repairs?

If you want to RMA search for “RMA” near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/