Jetson TX2 not powering up


Right now our team is working with JetsonTX2. We haven’t used it in 1-2 months and now we can’t power it up. CR5 led is on but the others are off. When we press power on button, CR6 led lights up momentarily and when we try the second option we can’t see the device from other computer’s linux terminal. We have checked the topics in the forums and we couldn’t find a solution. One of them suggested that the 1.8V power rails and the 3.3V power rails weren’t turning on. In that case we tried to check the power rails from the GPIO expansions and we can’t read any voltages from their VCC and GND. Should we be able to get a reading from these pins or how can we check the rails? Else if we can’t get a reading from those what should be our next steps? Any help would be appreciated.


We tried to open it again and it worked. As of now we can’t explain what exactly happened between those time periods as we haven’t touched it again but we are still posting here looking for more answers and for future referance if anybody somehow encounters this problem.

CR5 is for 19V input, CR6 is for 12V rail. Can you repro this issue stably? If not, it looks more like an occasional operation issue. If it can be repro stably, you can check the power on sequence as listed in TX2 Design Guide to make sure if all related signals are in correct timing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.