Jetson TX2 Shutdown/Reboot issue with L4T


I am using L4T to build BSP for Jetson TX2where I have applied patches for some of the interfaces.

I am able to Flash and boot the device but If I try to reboot the device or power off using command or using Ubuntu GUI its not getting turned off, It continues to show attached logs and never turns off. please help me

hello venkatraman.bhat,

please narrow down the issue by exclude the patches.
for example, are you having the same error with the default JetPack release image?


I have tried with Stock BSP and I find no such issues now with the stock BSP
Below are some modifications I have made anything may cause this issue? can you suggest me?
usb enable and i2c gpios removed. i2c mux bypassed
Updates made to SPI
disabled debug uart
rs485 mode enabled
added leopard camera support driver

hello venkatraman.bhat,

may I know what’s the removed GPIOs and bypassed I2C mux.
could you please have a try by adding them back for verification,

Yeah, the stock BSP I have tried is directly from NVIDIA and no changes, I made some changes for USB and it is working fine. attached the patch file for review.
Here I have applied 1 USB…diff and I find no issue. need to try one by one to debug the issue. did you find anything wrong?

1-usb-enable-i2c-gpios-removed.diff (20.7 KB) 2-i2c-mux-bypass.diff (2.3 KB)

hello venkatraman.bhat,

you might look into kernel logs for digging where stuck system to turned-off.
please setup serial console and checking carefully after reboot events.

I have checked and here is some update, if I try to apply changes for SPI then I get issue with reboot, do you think it has anything to do with the issue? or anything I am making wrong here?

We use SPI to communicate with a SAM controller on board.
SPI0_MOSI are used from the module. Please suggest on this

Any error message about SPI error?

Have a reference to below topic for enable SPI function.