Jetson Xavier USB issues


I have a Jetson Xavier that is having USB issues. I have successfully flashed this Xavier using the same Ubuntu 18.04LTS host in the past. When I recently booted up the Xavier both the USB Keyboard and Mouse would not work.

I have tried multiple USB hubs, both powered and non powered.

I have tried using both the USB Type C port and the USB Type A port and both do not work.

I have tried flashing the Xavier with JP 4.2.3 and with JP 4.3 and the same issues exist.

I have tried without a MicroSD card installed and without a monitor hooked up to the HDMI port and the two USB ports do not work.

I have connected to the MicroUSB serial port using Minicom from the host, see the attached output.

I have a non powered USB hub that has a power light that comes on when it is plugged into an active port. The USB hub has power when the Xavier is first powered on and then loses power at the same point in the boot process.

The USB error messages appear around [0005.515]. The USB power seems to be lost around [0009.667]

Any help I can get to debug this would be appreciated!
Xavier-NoHDMI-NoMicroSD-2.log (29.6 KB)

Be default the releases are with Ubuntu 18.04. Would suggest you use new Ubuntu version. When 10.04 was in use, type-C ports were not widely used. This can be one rootcause of the failure.

Sorry, that was a typo, I am using 18.04LTS. I have corrected the typo above as well.

If you have tried clean re-flash and the issue is still present, the hardware may be broken and you can go rma process.