Message "Failure to open MDL Table" show when export data to usd

When using the function of “Export as Prop” by Omniverse toolbox in Revit, occured error message “Failure to open MDL Table”.
How can I get the table?
Attached image is the setting from my Revit.
OS: Windows 10 Pro. (20H2, 19042.1348)
Omniverse Launcher: 1.3.4
Revit Connector: 105.1.2052
Revit: 2022


Thank you.

Hello @frank_liu! Thanks for reaching out to us with this issue. I have notified the dev team. We should hear back shortly.

The conversion table is put in /Omniverse/Revit folder. If you use Use Material Mapping, you’ll need it since it looks at the material names in Revit and finds a match for an existing PBR MDL material that we have in Omniverse.

You can still export nicely from Revit with just the Use Autodesk Materials since the Connector will convert the Autodesk materials into MDL for use in Omniverse.

This file, omniverseMDLtable.csv, is installed with the Connector. It’s possible that it was deleted. I’ve attached the shipping version of the CSV files that go in the /Omniverse/Revit folder.
omniverseFamilyDataTable.csv (104 Bytes)
omniverseMDLtable.csv (24.4 KB)
omniversePlantTable.csv (9.7 KB)
Readme.txt (3.3 KB)

@WendyGram @bharrison Thank you very much for help.
The Export process (from Revit to OV Create) looks fine and didn’t occur any error message.
But it seems something wrong during the data export to OV Create.
I use the model “Brownstone01” and export as prop to OV Create, but when I review on Create, there are only camera and light data (like attached image)
The model is the same as the model from the tutorial on Omniverse Youtube ( Getting Started with AutoDesk Revit Connector and Omniverse - YouTube)
Is there any wrong when I set the export options?

Setting Omniverse export options on Revit

The export result of Revit model on Create

Omniverse Launcher: 1.3.4
Omniverse Create: 2021.3.7
Revit Connector: 105.1.2052
Revit: 2022

BTW, I change Revit connector version to 104.2.2017 and Create version to 2021.3.5.
and get better result like below

Hi Frank,

What language is used for your Revit UI?
Can you try to launch your Revit with English UI?


Hi Takashi,

Thank you for the reply.
It looks fine after switching the language to ENU.
I will keep trying the model.
Thank you very much.

Hi Frank,

You are welcome! Good to hear you could solve the issue now.
As for material, I think you need to turn “Use Material Mapping” option ON.

Hi Takashi,

I have turned on the “Use Material Mapping” option on before export to usd.
Is there anything wrong of the model view on Create?
I use the latest Revit connector (105.1.2052) and OV Create (2021.3.7).

And I switch to “white mode” on Create.
By default, the view is like below when I load the usd file.

Thank you

Frank Liu

Apologies, you had already shared the settings in your previous post.
OK, then I’d like to ask if material name in Revit is non ascii character or not.
Can you also check the material name in Omniverse is just “_” (underbar) in your scene?

“the material name in Omniverse”
Do you mean the view below?
Sorry I’m not sure.

Thank you! Yes, that’s one of the way to check the name of materials in Omniverse.
So, for example, “Cabinets__Handles.mdl”, there are 2 “_” (underbar) in the middle of the name, and I think this material name in Revit is using non ascii character (non english alphabet). e.g. chinese character.
Can you confirm in your revit data?

Maybe the problem is cause by “-”?

I will try to switch the OS language to English(US).

Hi Frank,
Let me try the same Revit file on my side, and share the result with you.
I will send PM to you.