nano doesn't work after flashing JetPack 4.2.1 under windows


I flashed the the SD image JetPack 4.2.1 twice and it doesn’t seems to works.
A screen is connected to the hdmi port which remain black.
It’s connected to the router except only the yellow LED blink (not the green one). I see on the router the IP of the jetson but I can’t connect throuh ssh neither.
I also tried to connect through Serial console but nothing.


Are you sure the flash procedure finished? Even flashing the board would have uart log spew.
Did you see log during flash?

If you fallback to jetpack4.2, would it work again?

I flashed on Etcher under windows and after validating it successfully flashed. Since I am on windows I can’t flash the board. I believe I need to be on ubuntu?

I tried to flash JP 4.2 and it was same issue.

Ok, then we are talking about different “flash” here. I meant the flash procedure through sdkmanager.

I think it is better finding a ubuntu host and try.

But the JetPack 4.2 & 4.2.1 can be flashed under windows.
I updated the title to stay in topic (under windows)

Please share a screenshot for your Jetpack4.2 on windows. Not sure what do you mean.

sd-blob-b01.img is the 4.2.1 image
2019-03-18 is the 4.2 image
That’s all I can show.


The “flash” we are talking about are different things. Using etcher to update the sdcard is not what I wanted you to try. There are two ways to install the driver package to jetson nano

  1. Use etcher as your method
  2. Use sdkmanager or so-called jetpack on ubuntu host. It is a GUI tool which would use a script “” to flash the board.

Please try method 2 for this issue. We notice some users reporting that using etcher to update sdcard seems have some problems.

What you are asking can’t be done under Windows I guess.

That’s what I wanted to know. So I can’t flash under Windows for now.

Yes, so please find a ubuntu host first.

I tried under ubuntu with the command line to flash the jetpack :

/usr/bin/unzip -p ~/Downloads/ | sudo /bin/dd of=/dev/sd<x> bs=1M status=progress

And same issue again. Look like it’s not from etcher but the JetPack image itself or my nano.

I will try next to install sdk manager and flash from gui as u mentioned