Ro2 tutorial 7.2.7.4. Running Nav2

Hi everyone,

I’m using isaac sim 2022.2.1 with foxy
i’m following this tutorial-> 7.2.7. ROS2 Navigation — Omniverse IsaacSim latest documentation
I’m trying to run the following command

ros2 launch carter_navigation carter_navigation.launch.py
 keep getting this error:
Package 'carter_navigation' not found: "package 'carter_navigation' not found, searching: ['/.local/share/ov/pkg/isaac_sim-2022.2.1/ros2_workspace/install/isaac_ros_test', '/opt/ros/foxy']"

what am I doing wrong?

in which folder should that command be run?

1 Like

hi @alexander.aasmann , the package you are running (carter_navigation) cannot be found by ROS. Please make sure you build the ROS 2 workspace containing the package and source it before attempting to run it.

Follow the instructions here

1 Like

hi @rchadha. Thank you for the reply. I don’t seem to be able to access the page in the link

Hi @alexander.aasmann , apologies for the incorrect link please try this updated one

Hi, I followed this tutorial and it didn’t work. I had to source ros twice for it to work.

  1. source ros2_workspace/install/local_setup.bash

  2. source /opt/ros/foxy/setup.bash

any ideas why that’s the case?

Hi @alexander.aasmann , can you please elaborate on what did not work? A log/repro steps would be appreciated!

Sure, I followed all the steps from the tutorial, when i got to the point i which i was suppose to run the line,

ros2 launch carter_navigation carter_navigation.launch.py

i gave me the error mentioned on the initial question.

but running both commands before ros2 launch carter_navigation carter_navigation.launch.py solved my problem

1. source ros2_workspace/install/local_setup.bash
2. source /opt/ros/foxy/setup.bash

now it works

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.