Sekonix camera issue: overexposed images


The PX2 and camera was setup in a well lit office. The Sekonix 120degrees GMSL camera was connected to port A0 of PX2.

When the sample_camera_gmsl is ran, the image we got was very overexposed.

When we put the camera under the table (where it is dark), the image was correctly exposed.

We tested with another sekonix 120degrees camera on the same port A0, and it produced the same results as the first camera, hence this is not a camera hardware issue.

However when we tested a sekonix 60degrees camera connected to port A0, the image was correctly exposed.

We used the unmodified sample binaries that came with the PX2.

Our driveworks version is driveworks-0.2.1

Sekonix 120degree part number: SF3324-100 N2.0 RCCB
Sekonix 60degree part number: SF0828 Rev06 RCCB

Here are the sample images of the Sekonix camera 120deg vs 60deg

These cameras are bought from Nvidia together with the PX2.

Are there any settings that I need to do in the sample_camera_gmsl to get the correct exposed image?

Dear chee0007,

Could you please update DriveWorks version to 0.3? And then please re-try it. Thanks.

Thanks SteveNV. After updating firmware to 0.3, the camera is capturing the exposure correctly.

Hi SteveNV,

With driveworks-0.3, sample_camera_gmsl is capturing the single camera image of sekonix 120deg with the correct exposure.

However when i run sample_camera_multiple_gmsl with 3 sekonix 120deg cameras and 1 sekonix 60deg, the sekonix 120deg cameras all have the same overexposed images issue.

What could cause this issue? Is OpenGL displaying the RGBA image correctly? Or is the camera capturing the image with the wrong exposure?

Dear chee0007,

Can I get your using command and option sample_camera_multiple_gmsl? Thanks.

Hi SteveNV

I have connected 4 GMSL cameras in the following ports:
A[0] = Sekonix 120deg
A[1] = Sekonix 120deg
A[2] = Sekonix 120deg
A[3] = Sekonix 60deg

This command produced well exposed images of the three 120deg cameras
./sample_camera_multiple_gmsl --type-ab=ar0231-rccb --selector-mask=0111

This command produced overexposed images of the three 120deg camera, but the 60deg camera exposure is fine.
./sample_camera_multiple_gmsl --type-ab=ar0231-rccb --selector-mask=1111


  1. Are there any settings to set the 60deg and 120deg cameras on port A?
  2. What is the command if I were to connect and capture all 12 cameras connected to all ports A,B & C?

Hi chee0007,

We have been having a very similar problem until this afternoon when we discovered the fix. I’m posting our solution here in the hope that it might help you (or somebody else who finds this thread).

We have Sekonix SF3324-100 and SF3325-100 cameras. Using ar0231-rccb as the camera type, our images are terribly overexposed and green-tinted on all cameras. However, if you run the sample_sensors_info application in /usr/local/driveworks, you can find a list of possible camera-types, including ar0231-rccb-ss3322 and ar0231-rccb-ss3323, both of which gave us much better exposure and colour balance.

I’ve reached out to Sekonix to understand what this change means behind the scenes, but even in the absence of detailed information it’s worth trying these different camera-types to see if they give better results.

Another option for you, if your PX2 has cd or ef camera groups like ours does, would be to connect the different camera models to different groups and use --type-cd and --type-ef to set different camera types.

I hope that helps and good luck