Setting up Quanergy M8-1 Rev C1 LIDAR with the Drive PX2

As the title says, I would like to set up the Quanergy M8 LIDAR with the Drive PX2. Quanergy support teams mentioned that there’s a specific driver for setting it up. If I get access to the download link, that would help. Also, a general overview of the setup procedure as well as accessing the LIDAR through the Drive PX2 would help a lot. Thanks.

Dear Vizer1993,

We provide NVIDIA_DriveWorks_DevGuide doc in DriveWorks folder on DPX2.
Please see “Lidar Data Acquisition” part. Thanks.

Dear Steve,

Could you point out where I may find this folder on the DPX2?

Thanks.

Dear Vizer1993,

Please see /usr/local/driveworks/doc in DPX2 and run index.html file.
You can see Development Guide on left side window and click “HERE” on the right side window then you can open the file. Thanks.

Hi Steve,

I ran the following on a terminal -

ubuntu@tegra-ubuntu:/usr/local/driveworks-0.2.1/bin$ ./sample_lidar_replay --ip=10.24.250.171 --port=7780 --device=QUAN_M81A --scan-frequency=10
Program Arguments:
–device=QUAN_M81A
–file=…/./data/samples/sensors/lidar/lidar_sample.bin
–ip=10.24.250.171
–offscreen=0
–port=7780
–scan-frequency=10

nvrm_gpu: Bug 1781434 workaround enabled.
nvrm_gpu: Bug 1778448 workaround enabled.
Initialize DriveWorks SDK v0.2.1
Release build with GNU 4.9.2 from v0.2.1-rc6-0-g684729c against PDK v4.1.4.0
SDK: no resource mounted
SDK: Create NvMediaDevice
egl::Display: found 2 EGL devices
egl::Display: use drm device: drm-nvdc
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> lidar.socket, ip=10.24.250.171,port=7780,device=QUAN_M81A,scan-frequency=10
LidarSocket: connected to 10.24.250.171:7780
LidarSocket: Device disconnected
SDK: Release NvMediaDevice
Driveworks SDK released
ubuntu@tegra-ubuntu:/usr/local/driveworks-0.2.1/bin$

It seems the LIDAR connects to the DPX2 for a few seconds and then gets disconnected again. I have connected the LIDAR’s ethernet cable to the blue Gigabit ethernet port on the DPX2, that’s on the Vehicle cable harness.

Please help me resolve this issue, also, if you refer to any docs or guides please provide me with the exact link or location of where I can find those docs (be it on the driveworks folder or online).

I have already looked at usr/local/driveworks-0.2.1/doc/nvdwx_html/dwx_lidar_replay_sample.html, and there are no troubleshooting options there for the issue I am facing right now.

Thanks.

Also, the LIDAR I have with me is a Quanergy M8-1 Rev. C1. I would like to know if this LIDAR is supported in the first place. The DriveWorks SDK Reference 0.2.1 Release states that the currently supported Quanergy device is the Quanergy M8 [QUAN_M81A].

Thanks.

Hello Vizer1993,

The port should be 4141 instead of 7780. 7780 is the http (settings) port but 4141 is the data port. Please let me know if this works for you.

Thank you,

Quanergy Support

Hello,

I recently Flash our PX2 to version 5.0.5a, and I was under the impression that the Quanergy M8 [QUAN_M81A] driver was part of the NVIDIA PX2 this new distribution. After the update, I have not been able to run our LIDAR because there is no driver. I cannot find the Quanergy M8 [QUAN_M81A] driver for the PX2 anywhere. I have written to Quanergy Systems support, but I have not had an answer other than the confirming receive.

Can anyone tell me where can I find the driver?

Thanks

lgriera,

Strange I am using the same version (although a 5.0.5b is available) and it is working. My command line:

sample_lidar_replay --protocol=lidar.socket --params=device=QUAN_M81A,ip=lidar_IP,port=4141,scan-frequency=10 --show-intensity=true

Try again using this example.

Tiago