trouble with install script


I downloaded the tar file off your website and then followed the directions in INSTALL.txt to make a directory for it and then run the install script by doing sudo ./install (it failed without sudo).

However, “after installation” I am not getting a message telling me my host id or anything like it says I should get. Thus, I cannot get a trial key on the website.

Secondly, how do I know the script ran correctly? I sometimes get messages like ‘can’t cd to…’

I am trying to do a single machine installation (no network stuff) and I already checked that my permissions of /dev/null are correct.


I am having the same problem, but I’ve had no response from support yet.

What OS are you running?

I’m running Ubuntu 11.10


I suspect you have one of these problems.

  1. If you are trying to generate license online form the install script.
    It doe snot work very well on Linux yet. I recommend you do it
    by hand. Click on ‘create temporary keys’ on your web account

% lmutil lmhostid

use of the 12-digit outputs for the trial license.

  1. % lmutil lmhostid
    is only returning all zeros, all Fs, or blank. This is configuration problem.
    The flexlm utils cannot detect your MAC addresses. It may come down to changing the
    configuration form ‘em1’ to ‘eth0’ in order for the MAC address be detected.

  2. The 12.* compilers use new versions of flexlm that require
    ‘Linux Standard Base’ aka ‘lsb’ be present. You can still
    use the flexlm software that came with 11.* release, but
    you will eventually need lsb installed on linux.

The most common symptom of the problem will be
a message when you run the compilers
$PGI/linux86-64/12.5/bin/lmutil: No such file or directory

To determine if the problem is lsb, type
% lsb_release
if it returns core-3.0 or higher, you have lsb.

If less than 3.0 or ‘n/a’ is returned, you need to install it,
and then run the compilers.

For ubuntu, the process is

% apt-get lsb install

on other Linux versions, you need to find the rpm and
install it.

I have re-enabled your web accounts to generate trial licenses.


Hi Dave, thanks for the feedback.

I have run the install script and opted to license online now, and as far as I can tell, the software is now installed. I am also getting my flexhostid just fine.

However, when trying to ‘verify the release number of the installed software’ (installation guide linux step 4) I am having trouble. In the terminal I type ‘pgf77 -V x.f’ or ‘pgfortran -V x.f’ and I get ‘command not found’. Note I have not obtained my trial license yet- I am waiting to do this until I need to. Sorry if I’m just being dumb.


Hi Ben,

Can you check if you the PGI bin directory in your PATH environment variable? This is the typical cause of this error.

  • Mat

Thanks that fixed it.