Unable to connect to localhost - credentials or the user does not exist

I installed omniverse 2 days ago. The local serever has been created due to the invidia instraction, I sat my own username and password and everything was working fine for 2 days.
I made some project and saved it in “Projects” folder in the localhost area.

When after two days I tried to log in to localhost (as before) I got the message: “Wrong credentials or the user does not exist.”

But Nucleus seems to be working fine, when I go to the settings it opens “localhost:3080” in browser and everything is marked as “RUNNING” (green) there.
I can also log in to localhost using “admin” (user name and password). In that case server is starting to work but my project files are missing.

Is there an option to log in using my credentials (these ones I set earlier),
or any other option to restore my project files after I log in as an admin?

@katarzyna.szymanska i am just another user passing by - do you see your old account name inside the ‘Users’ folder by chance? I am trying to see if it’s possible for you to reset the password to your initial account as admin (if it’s present in the Users folder):


@Simplychenable No - I can’t see any of my old data in any folder. All folders are empty, it looks like it was totally clear newly installed server

is it possible for you to upload your Launcher log? there may be additional information that could help with the troubleshooting. here is where you can find the .log file:

  • Windows - C:\Users\%username%\.nvidia-omniverse\logs\launcher.log
  • Linux - ~/.nvidia-omniverse/logs/launcher.log

launcher.log (221.8 KB)

was there anything that occurred two days ago between when it was working vs when it stopped working (that you know of)? was there any new antivirus/network/windows update?

@katarzyna.szymanska can you please validate where your DATA PATH is pointing to (You can get to this in the launcher->settings)? Is this where it was originally pathed, or did you have it pointed somewhere else previously?


  1. @Simplychenable Speaking of Windows updates, I also thought about it earlier ;)
    There have been some windows update, I found it in update history. I uninstalled everything I could but it didn’t help (although I couldn’t uninstall everything even though I’m an admin. There simply wasn’t an option).
    I personally did not install any new antiviruses or firewalls, etc

  2. @dlindsey My data path (and other paths) are as you can see. I set them this way right after Omniverse instalation and I haven’t changed them since I started work. Oryginaly my first localhost server was working fine with these paths

Hello again.
I’m writing because something strange has happened since I reported the above problem.
After I couldn’t log in with credentials I specified at the beginning (but log in as an admin/admin worked, just my previous project desapeared), I installed Nucleus again and sat “admin” as the name and password.

So to summarize the story:
First installed localhost - name “katarzynka”
First project on “katarzynka” - “001-PalletJack.usd”

Second time installed localhost - name “admin”
New project on “admin” - “Demo_Palace.usd”

For last couple days verything went fine, but today for no reason Nucleus lost connection and I had to log in again (I didn’t lose internet connection, just Nucleus stoped running).
I logged in as admin/admin.
It turned out that my last project “Demo_Palace.usd” disappeared,
Instead, the old project “001-PalletJack.usd” appeared again.
I can also log in again using my old credentials - the same ones that stopped working a few days ago, which was the reason for my first posts here.

Has anyone had a similar experience?
Why is localhost behaving so strangely?

launcher.log (415.5 KB)

the behavior does sound peculiar. to confirm, you now lost access to the Demo_Palace.usd under both logins?

i can’t say i have experienced this in the past, one speculation based on the log is that something to do with the token and how it is being refreshed. but this isn’t something i can make in-depth comment about since it’s all happening under the hood and the mods/devs would have clearer understanding.

Yes, I confirm that I have lost access to the “Demo_Palace.usd” project. In the screenshots attached above, you can see that only the “001-PalletJack.usd” project was available. It didn’t matter whether I logged in as localhost-“admin” or as localhost-“katarzynka”, the project view was the same.

@Simplychenable Maybe the clue you gave about refreshing is the right one…
Because I bring you another interesting fact:
After writing the previous post, I turned off the computer. Now, after a few hours, I turned it on again and launched omniverse. I didn’t have to log in to localhost because Nucleus was still active as “katarzynka” (just as I left it when I turned off the computer).
However, the content of the project folder in localhost has changed again!
Now the “001-PalletJack.usd” project has disappeared again.
However, other projects have returned, including “Demo-Palace.usd”.
I am attaching a screenshot with the current preview.
And really, I didn’t change any settings on the computer, and there was no Windows update.

I’ve already checked one more thing - I’ve logged out from localhost “katarzynka” and try to log in again.
And I have the same problem as at the beginning - “katarzynka” is no longer available.
Only “admin” works for log in.

I think you should simply delete all users except admin and go from there. When its just you on your local machine, there is no need to have multiple users. I think it is over confusing in this point. Just another point of view but you do not have to even use Nucleus, if its just you and one user. You can just store files normally on the hard drive.