Unable to flash jetson xavier nx


I am using jetson xavier nx production module with custom board similar to xavier devkit
I am trying to flash the jetson xavier nx but the flashing process getting terminated.

I have flashed the board number of times before as well but this time i am facing this issue. I am using the sdk manager tool, host machine with ubuntu 20.04, jetpack : 5.1.2

. I have attached the error image below

I have confirmed the the usb is connected to the host and jetson in between the process
I tried with different host machine with ubuntu 20.04 as well the issue continues


It seems that the board value being read from your board’s EEPROM doesn’t match the Xavier NX module. If you are sure that you have the correct module, it could be that the EEPROM is corrupted. I have seen posts on here about manually reading and correcting the EEPROM values, but I haven’t tried it myself.

Here are the values for the different boards:

Building the massfuse blob with OFFLINE method requires:
   Same as ONLINE method. See ``Building the Massfuse Blob with ONLINE
   method'' above.

   To generate the massfuse blob with OFFLINE method:

   - Enter the command `cd Linux_for_Tegra`.
   - No actual jetson device attachment is necessary.
   - Just add ``BOARDID=<boardid> BOARDSKU=<sku> FAB=<fab>'' in front of
     ``./nvmassfusegen.sh'' as in ONLINE method:
     BOARDID=<boardid> BOARDSKU=<sku> FAB=<fab> \
     FUSELEVEL=fuselevel_production ./nvmassfusegen.sh \
     <odm fuse options> <device_name>
   Where actual values are:
                                      BOARDID  BOARDSKU  FAB  BOARDREV
     jetson-agx-xavier-industrial     2888     0008      600  A.0 
     jetson-xavier-nx-devkit-tx2-nx   3636     0001      100  B.0 
     jetson-xavier-nx-devkit-emmc     3668     0001      100  N/A 
     jetson-nano-devkit-emmc          3448     0002      200  N/A 
     jetson-agx-xavier-devkit (16GB)  2888     0001      400  H.0 
     jetson-agx-xavier-devkit (32GB)  2888     0004      400  K.0 
     jetson-tx2-devkit                3310     1000      B02  N/A 
     jetson-tx2-devkit-tx2i           3489     0000      300  A.0 
     jetson-tx2-devkit-4gb            3489     0888      300  F.0 
     jetson-tx1-devkit                2180     0000      400  N/A 

I hope this helps.

I tried the given offline method by connecting the board to my host pc , board in force recovery mode.

I am receiving invalid target board error as below

I got it resolved.

If someone face the same issue ever.
Goto the downloaded sdk manager folder Linux_for_Tegra .
use this command to flash
sudo SKIP_EEPROM_CHECK=1 BOARDID=3668 BOARDSKU=0001 ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

jetson-xavier-nx-devkit-emmc → for 16 GB production module
jetson-xavier-nx-devkit → for developer kit

The above command will skip reading the board information from the eeprom instread we will provide the board info as arguments.

Thanks to @miguel.taylor for providing the board information

1 Like

@dxt please remember to update the eeprom content back to normal as you can boot up now.

can you provide the steps for that ?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.