Unable to start in VR

Hi,
I’ve tried with both 2022.1.1 and 2022.1.0 to start in VR by using ./isaac-sim.xr.steamvr.sh.
However in both cases isaac sim crashes. I’ve tried with the simulation running and not and different exemple scene but always the same result. I’ve also tried with driver 470, 510 and 520 and all lead to crash.
What could be the issue ?

Attached is one of the many crash report. I am also unable to get the minidump to save to disk so maybe this could provide more information

crash_2022-11-07_18-08-21_40414.txt (4.2 KB)

Also here is the backtrace from the log

2022-11-08 15:42:50 [308,037ms] [Fatal] [carb.crashreporter-breakpad.plugin] Thread 98057 backtrace follows:
2022-11-08 15:42:51 [308,391ms] [Fatal] [carb.crashreporter-breakpad.plugin] 000: libcarb.events.plugin.so!std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string()+0xde4 (??:?)
2022-11-08 15:42:51 [308,720ms] [Fatal] [carb.crashreporter-breakpad.plugin] 001: libcarb.assets.plugin.so!std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(std::string const&, unsigned long, unsigned long)+0x8e54 (??:?)
2022-11-08 15:42:51 [309,095ms] [Fatal] [carb.crashreporter-breakpad.plugin] 002: libcarb.datasource-file.plugin.so!std::basic_string<char, std::char_traits<char>, std::allocator<char> >::~basic_string()+0x424 (??:?)
2022-11-08 15:42:52 [309,451ms] [Fatal] [carb.crashreporter-breakpad.plugin] 003: libgpu.foundation.plugin.so!std::fill(std::_Bit_iterator, std::_Bit_iterator, bool const&)+0x374 (??:?)
2022-11-08 15:42:52 [309,809ms] [Fatal] [carb.crashreporter-breakpad.plugin] 004: libcarb.datasource-omniclient.plugin.so!std::_V2::condition_variable_any::~condition_variable_any()+0x1044 (??:?)
2022-11-08 15:42:53 [310,169ms] [Fatal] [carb.crashreporter-breakpad.plugin] 005: libomni.kit.renderer.plugin.so!std::__future_base::_Result<carb::datasource::Connection*>::_M_destroy()+0x3674 (??:?)
2022-11-08 15:42:53 [310,558ms] [Fatal] [carb.crashreporter-breakpad.plugin] 006: librtx.materialdb.plugin.so!std::mutex::lock()+0x224 (??:?)
2022-11-08 15:42:53 [310,915ms] [Fatal] [carb.crashreporter-breakpad.plugin] 007: libpthread.so.0!funlockfile+0x60 (sigaction.c:?)
2022-11-08 15:42:54 [311,257ms] [Fatal] [carb.crashreporter-breakpad.plugin] 008: vrclient.so!LfMutexUnlockRobust(LfMutex*)+0x38 (??:?)
2022-11-08 15:42:54 [311,595ms] [Fatal] [carb.crashreporter-breakpad.plugin] 009: vrclient.so!CSyncLockThread::Run()+0x9a (??:?)
2022-11-08 15:42:54 [311,923ms] [Fatal] [carb.crashreporter-breakpad.plugin] 010: vrclient.so!SteamThreadTools::CThread::ThreadProc(void*)+0xb9 (??:?)
2022-11-08 15:42:55 [312,323ms] [Fatal] [carb.crashreporter-breakpad.plugin] 011: libpthread.so.0!start_thread+0xd9 (/build/glibc-SzIz7B/glibc-2.31/nptl/pthread_create.c:478 (discriminator 6))

And here is the full log
kit_20221108_154654.log (1.1 MB)

VR is only supported on windows currently.
Apologies for the confusion we will remove /isaac-sim.xr.steamvr.sh. for future releases

Thanks,

I am fine running it from Windows, however the Windows version doesn’t seem to work with ROS2. And I need both for my setup. What would you recommend

1 Like

Is there any tutorial on how to start Isaac sim in VR ?

Not really but you just need to launch isaac-sim.xr.steamvr.sh and you should have a windows called VR and then a button startVR