How to use Aurix CAN on Orin

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

As I was testing CAN interface on agx orin following the instructions:

https://developer.nvidia.com/docs/drive/drive-os/6.0.6/public/driveworks-nvsdk/dwx_canbus_logger_sample.html

I did succussfully recieved data using port11 with can0 and port12( with a custum cable reversing pin1 and pin2, pin7 and pin8) with can1 using Socket Can.

However, we need at least 4 channels, so my question is how to use the Aurix CAN.
I’ve tried
./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,inIDMap=1:0x106+2:0x206,outIDMap=0x105:17+0x205:18
or
./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=f,inIDMap=5:0x506+6:0x606,outIDMap=0x505:21+0x605:22
But that doesn’t seem to work

aurix version:
DRIVE-V6.0.6-P3710-AFW-Aurix-StepB-5.07.06
while agx running Drive OS 6.0.4 patch1
Not sure if it matters

Dear @jiayu.yang
Please check At the Drive Orin, Please tell me the model number for testing CAN and how to test all CAN ports - #7 by SivaRamaKrishnaNV if it helps

I’ve read that thread before. As far as my understanding, we are not on the same topic.
I do undersand the fact that there’s only two can devices on agx linux, I can also see that in /dev/
But that’s socket can.

As I mentioned in the quesion:
https://developer.nvidia.com/docs/drive/drive-os/6.0.6/public/driveworks-nvsdk/dwx_canbus_logger_sample.html


It saids quite clear that we should be able to use AurixCAN with the --driver and the --params arguments as shown in the screenshot, which turns out not working on my machine. I don’t know whether I connected to the wrong port or I had the wrong arguments.


This also shows that it support 6 CAN channels, from a to f.

Hello @SivaRamaKrishnaNV,

Do we have any updates here?

After some digging, I found a instuction in the DRIVE-V6.0.4-P3710-AFW-Aurix.zip, shown as below.

All I need is receiveing data through these Aurix channels, not modifying anything. And all the documantations indicate that this should work out of the box. But I failed to find the instruction about how to use this exactly. Could you please help me out with this?

Dear @jiayu.yang,
The document seems to miss the information on this. I will check internally and update you. May I know which Harness cable you have?

Hello @SivaRamaKrishnaNV ,

I’m using the P3718-H2A-A cable, following this instruction.
DI-10587-003_v02.pdf (26.7 MB)

I’ve also tried the command cycliccanon CAN in minicom without connecting anything on the harness port. I did successfully receved messages on both CAN0 and CAN1 using can.socket, which means the commend is working. Then I tried the commend as follows, nothing happend.

./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,inIDMap=1:0x106+2:0x206+3:0x306+4:0x406+5:0x506+6:0x606,outIDMap=0x105:17+0x205:18+0x305:19+0x405:20+0x505:21+0x605:22

I tried ping 10.42.0.146 on the AGX, it did respond, which means the ip is correct. So I guess we first need to conform the inIDMap/outIDMap is right. I failed to findout this part of the imformation, so I followed the instuction for Drive OS 5.2.6 instead, which could very possible be wrong for the Orin Dev Kit. Then we can move on to figure out which pin on which port on the Harness cable maps to which CAN.

Hello @SivaRamaKrishnaNV ,

It had been a week for now, do we have any updates?

Hello @SivaRamaKrishnaNV ,

do we have any updates?

Dear @jiayu.yang,
we identified it as a bug but we will not be able to fix it for DRIVEOS 6.x.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.