Jetson TX2 and J120 -- Not booting or powering on

I feel like I am missing something. I plugged in a TX (which has already been flashed) into the J120 board, and go to power it up. Watching on the power supply there is a little jump from 7mah to 14 then back to 7 and it stays that way. The green light turns on and then flashes. I tried powering on and off several times. I tried applying power to solder points and saw no difference.

What I am missing?

I tried pushing the power button, it sometimes jumps a bit to mah of draw, same with reset. I feel like the board is not sending the right signal to the TX 2 to turn on? Bad board maybe? Maybe it is that it was flashed for an Orbitty Carrier board before?

When the green led on the J120 nearby the micro usb port flashes after you connected power it should be working ok.
If you flashed your TX2 on another carrier board and you did not incorporate the necessary device tree changes for the J120, it will almost certainly not operate correctly.
What Jetpack version are you using?