Orbitty carrier with jetson

I want to use the Orbitty carrier board. At present, Jetpack 4.3 is installed in Jetson.

1.Is the word host computer not jetson but a desktop computer?
2.2. Will Jetson be initialized if it is installed according to the manual?

Hi gpqls7669,

I can’t answer it, you may try to find more information from their product link: http://connecttech.com/product/orbitty-carrier-for-nvidia-jetson-tx2-tx1/

Hey gpqls7669,

Yes Host computer is your desktop computer not the Jetson.

You need to install the carrier boards firmware according to the instructions provided from orbitty. I would follow the link kayccc provided and start there. Go to downloads and find the L4T board support packages tab, there you will see several versions of the board support packages that each can only be installed along side the specified versions of jetpack.

you will need to download the NVIDIA sdkmanager and install your orbitty board support package midway through the process. NVIDIA does not provide a great way of pausing the installation to migrate your BSP files for flashing jetpack in the sdkmanager but there are guides out there. You can try to follow the steps I provide in my post here:

Note those steps worked for the J120 auvidea carrier board, I have an orbitty board that I will perform the same procedure on in about a week so I can update you on any modifications needed to the steps I provided for the J120.


Hi, thanks for reply.
If I install jetpack like that, will the existing jetson data disappear? The problem can be solved by connecting orbitty carrier. At present, Jetpack 4.3 is already installed in Jetson. Only the usb of the Orbitty carrier is not working.