Problem installing Intel d435 camera

Hi all im trying to install my camera with orin nx ,i have been trying this for like 2-3 days !

I tried many ways-steps and still got nothing.

System :
Linux nvidia-orin-nx 5.10.104-tegra aarch64 Ubuntu 22.04

1)I tried to install from here : librealsense/ at master · IntelRealSense/librealsense · GitHub

still i got :
E: Unable to locate package librealsense2-utils
E: Unable to locate package librealsense2-dkms

Also when i try to change kernels and boot from another one i cant configure grubs because guess what,there is none!

2)Also i tried with ros2 and i cant install humble ros2! Still cant find packages !

3)Also my version of jetpack is 35.0 so again i cant install it from there and i cant install sdk from nvidia official website! System errors …

4)CMake cant do it either i have missing files that in intel github described that there must have been

5)I’ve tried again to boot and pass again ubuntu 18.04 and my usb-stick cant rezognize !

What is happening ?!

Hi thanosrom95,

We verify the D435 is working on Orin-NX + r35.3.1.
Please reference below steps:

git clone
cd librealsense/
sudo apt install libudev-dev pkg-config libgtk-2-dev
sudo apt install libudev-dev pkg-config libgtk-3-dev
sudo apt install libusb-1.0-0-dev pkg-config
sudo apt install libglfw3-dev
sudo apt instlal libssl-dev
sudo apt install libssl-dev
sudo apt-get install libglfw3-dev libgl1-mesa-dev libglu1-mesa
sudo apt install cmake
sudo cp config/99-realsense-libusb.rules /etc/udev/rules.d/.
sudo udevadm control --reload-rules && udevadm trigger
mkdir build
cd build/
cmake ../ -DBUILD_EXAMPLES=true
sudo make install
cd tools/realsense-viewer
1 Like

Thank you very much it worked !!

Sorry but i cant install ros humble too , it is unable to locate the package ,any solution about this ?
Foxy seems to work but i am not sure about the results.

Thanks in advance.

Are you sure you’re running Ubuntu 22.04 and not 20.04?

Yiep , i copy paste the response from the terminal.Its 100% ubuntu 22.04 .
It cant find the package , it has so many restrections in packages with arm64 i guess … maybe i need to use something like cmake again.

please share the complete failure for checking.

I asked because, as far as I know, Ubuntu 22.04 will be available with Jetpack 6 at the end of the year for ORIN platforms. You said you’re using Jetpack 35.0 but apparently it’s not in the Jetpack list (JetPack Archive | NVIDIA Developer). Did you mean either 35.2.1 or 35.3.1 (that are the only ones that support ORIN NX)? Those come with Ubuntu 20.04 though.

How did you flash it?
Lack of ROS2 Humble apt packages also points to Ubuntu 20.04, which needs you to compile it by sources. On the other hand, ROS2 Foxy packages are available.

Hello , i send it for now in a co-worker , i will come back for details.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.